package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{3}\.\d{3}\.\d{3}\s{3}(?:.*\/ )?(.+)$`)
var str = `030.000.208 OUTRA COISA
001.005.001 ALGUMA / COISA AQUI COM - TAMBÉM / GERAL.ASSINADA-COISA
040.001.218 OUTRA COISA / AQUI OUTRA/COISA GERAL
000.000.003 ALGUMA / COISA AQUI COM - TAMBÉM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}