import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{3}\\.\\d{3}\\.\\d{3}\\s{3}(?:.*\\/ )?(.+)$";
final String string = "030.000.208 OUTRA COISA\n"
+ "001.005.001 ALGUMA / COISA AQUI COM - TAMBÉM / GERAL.ASSINADA-COISA\n"
+ "040.001.218 OUTRA COISA / AQUI OUTRA/COISA GERAL\n"
+ "000.000.003 ALGUMA / COISA AQUI COM - TAMBÉM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}