const regex = /^\d{3}\.\d{3}\.\d{3}\s{3}(?:.*\/ )?(.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{3}\\.\\d{3}\\.\\d{3}\\s{3}(?:.*\\\/ )?(.+)$', 'gm')
const str = `030.000.208 OUTRA COISA
001.005.001 ALGUMA / COISA AQUI COM - TAMBÉM / GERAL.ASSINADA-COISA
040.001.218 OUTRA COISA / AQUI OUTRA/COISA GERAL
000.000.003 ALGUMA / COISA AQUI COM - TAMBÉM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}