using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.){1}(?<!;|\n|\r|\t)("")(?!;|\n|\r|\t)(.){1}";
string substitution = @"$1$3";
string input = @"""ModifTextePub"";""ModifObservation"";""Resume""Vitrine"";""Observations""Criteres"";""InternetOK"";""NumPhoto"";""AmianteLe"";""SNavantLe"";""ActePrec"";""ProprietairesPrec"";""Situation"";""FraisNotaires""";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}