re = /(.){1}(?<!;|\n|\r|\t)(")(?!;|\n|\r|\t)(.){1}/
str = '"ModifTextePub";"ModifObservation";"Resume"Vitrine";"Observations"Criteres"";"InternetOK";"NumPhoto";"AmianteLe";"SNavantLe";"ActePrec";"ProprietairesPrec";"Situation";"FraisNotaires"'
subst = '$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result