import Foundation
let pattern = #"(.){1}(?<!;|\n|\r|\t)(")(?!;|\n|\r|\t)(.){1}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #""ModifTextePub";"ModifObservation";"Resume"Vitrine";"Observations"Criteres"";"InternetOK";"NumPhoto";"AmianteLe";"SNavantLe";"ActePrec";"ProprietairesPrec";"Situation";"FraisNotaires""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)