const regex = /(.){1}(?<!;|\n|\r|\t)(")(?!;|\n|\r|\t)(.){1}/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.){1}(?<!;|\\n|\\r|\\t)(")(?!;|\\n|\\r|\\t)(.){1}', 'gs')
const str = `"ModifTextePub";"ModifObservation";"Resume"Vitrine";"Observations"Criteres"";"InternetOK";"NumPhoto";"AmianteLe";"SNavantLe";"ActePrec";"ProprietairesPrec";"Situation";"FraisNotaires"`;
const subst = `$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);