#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+(?:7(?: (?:\((?:\d{1,3}(?:\)(?: (?:\d{1,3}(?:-(?:\d{1,2}(?:-\d{0,2})?)?)?)?)?)?)?)?)?)?$"
Local $sString = "+" & @CRLF & _
"+7" & @CRLF & _
"+7 " & @CRLF & _
"+7 (" & @CRLF & _
"+7 (1" & @CRLF & _
"+7 (12" & @CRLF & _
"+7 (123" & @CRLF & _
"+7 (123)" & @CRLF & _
"+7 (123) " & @CRLF & _
"+7 (123) 4" & @CRLF & _
"+7 (123) 45" & @CRLF & _
"+7 (123) 456" & @CRLF & _
"+7 (123) 456-" & @CRLF & _
"+7 (123) 456-7" & @CRLF & _
"+7 (123) 456-78" & @CRLF & _
"+7 (123) 456-78-" & @CRLF & _
"+7 (123) 456-78-9" & @CRLF & _
"+7 (123) 456-78-90" & @CRLF & _
"" & @CRLF & _
"+7 (123) 456-78-902" & @CRLF & _
"+7 (123) 45678-90" & @CRLF & _
"+7 123 456-78-90"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")