re = /^\+(?:7(?: (?:\((?:\d{1,3}(?:\)(?: (?:\d{1,3}(?:-(?:\d{1,2}(?:-\d{0,2})?)?)?)?)?)?)?)?)?)?$/m
str = '+
+7
+7
+7 (
+7 (1
+7 (12
+7 (123
+7 (123)
+7 (123)
+7 (123) 4
+7 (123) 45
+7 (123) 456
+7 (123) 456-
+7 (123) 456-7
+7 (123) 456-78
+7 (123) 456-78-
+7 (123) 456-78-9
+7 (123) 456-78-90
+7 (123) 456-78-902
+7 (123) 45678-90
+7 123 456-78-90'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end