import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+(?:7(?: (?:\\((?:\\d{1,3}(?:\\)(?: (?:\\d{1,3}(?:-(?:\\d{1,2}(?:-\\d{0,2})?)?)?)?)?)?)?)?)?)?$";
final String string = "+\n"
+ "+7\n"
+ "+7 \n"
+ "+7 (\n"
+ "+7 (1\n"
+ "+7 (12\n"
+ "+7 (123\n"
+ "+7 (123)\n"
+ "+7 (123) \n"
+ "+7 (123) 4\n"
+ "+7 (123) 45\n"
+ "+7 (123) 456\n"
+ "+7 (123) 456-\n"
+ "+7 (123) 456-7\n"
+ "+7 (123) 456-78\n"
+ "+7 (123) 456-78-\n"
+ "+7 (123) 456-78-9\n"
+ "+7 (123) 456-78-90\n\n"
+ "+7 (123) 456-78-902\n"
+ "+7 (123) 45678-90\n"
+ "+7 123 456-78-90";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}