const regex = new RegExp('^\\+(?:7(?: (?:\\((?:\\d{1,3}(?:\\)(?: (?:\\d{1,3}(?:-(?:\\d{1,2}(?:-\\d{0,2})?)?)?)?)?)?)?)?)?)?$', 'gm')
const str = `+
+7
+7
+7 (
+7 (1
+7 (12
+7 (123
+7 (123)
+7 (123)
+7 (123) 4
+7 (123) 45
+7 (123) 456
+7 (123) 456-
+7 (123) 456-7
+7 (123) 456-78
+7 (123) 456-78-
+7 (123) 456-78-9
+7 (123) 456-78-90
+7 (123) 456-78-902
+7 (123) 45678-90
+7 123 456-78-90`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}