using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+(?:7(?: (?:\((?:\d{1,3}(?:\)(?: (?:\d{1,3}(?:-(?:\d{1,2}(?:-\d{0,2})?)?)?)?)?)?)?)?)?)?$";
string input = @"+
+7
+7
+7 (
+7 (1
+7 (12
+7 (123
+7 (123)
+7 (123)
+7 (123) 4
+7 (123) 45
+7 (123) 456
+7 (123) 456-
+7 (123) 456-7
+7 (123) 456-78
+7 (123) 456-78-
+7 (123) 456-78-9
+7 (123) 456-78-90
+7 (123) 456-78-902
+7 (123) 45678-90
+7 123 456-78-90";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}