// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+(?:7(?: (?:\((?:\d{1,3}(?:\)(?: (?:\d{1,3}(?:-(?:\d{1,2}(?:-\d{0,2})?)?)?)?)?)?)?)?)?)?$").unwrap();
let string = "+
+7
+7
+7 (
+7 (1
+7 (12
+7 (123
+7 (123)
+7 (123)
+7 (123) 4
+7 (123) 45
+7 (123) 456
+7 (123) 456-
+7 (123) 456-7
+7 (123) 456-78
+7 (123) 456-78-
+7 (123) 456-78-9
+7 (123) 456-78-90
+7 (123) 456-78-902
+7 (123) 45678-90
+7 123 456-78-90";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}