package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<curlyStuff>\{[^}]+\})?(?P<nodeName>\w+)\b`)
var str = `nodeName1
{http://datex2.eu/schema/2/2_0}nodeName2
nodeName3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}