import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<curlyStuff>\\{[^\\}]+\\})?(?P<nodeName>\\w+)\\b";
final String string = "nodeName1\n"
+ "{http://datex2.eu/schema/2/2_0}nodeName2\n"
+ "nodeName3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}