const regex = new RegExp('(?P<curlyStuff>\\{[^}]+\\})?(?P<nodeName>\\w+)\\b', 'g')
const str = `nodeName1
{http://datex2.eu/schema/2/2_0}nodeName2
nodeName3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}