// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<curlyStuff>\{[^}]+\})?(?P<nodeName>\w+)\b").unwrap();
let string = "nodeName1
{http://datex2.eu/schema/2/2_0}nodeName2
nodeName3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}