$re = '/(?P<curlyStuff>\{[^}]+\})?(?P<nodeName>\w+)\b/';
$str = 'nodeName1
{http://datex2.eu/schema/2/2_0}nodeName2
nodeName3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);