using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([H|G]{1}[0-9]+)\)";
string input = @"<span style=\""color: red; font-weight: bold;\""> (G4) The same as <a class=\""nowrap\"" href=\""lexicon.cfm?strongs=H9&t=KJV\"" title=\""English: lost thing, that which was lost\""><span class=\""Hb\"">אֲבֵדָה</span> (H9)</a>, incorrectly written for <a class=\""nowrap\"" href=\""lexicon.cfm?strongs=H11&t=KJV\"" title=\""English: destruction\""><span class=\""Hb\"">אֲבַדּוֹן</span> (H11)</a> ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}