// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(([H|G]{1}[0-9]+)\)").unwrap();
let string = "<span style=\\\"color: red; font-weight: bold;\\\"> (G4) The same as <a class=\\\"nowrap\\\" href=\\\"lexicon.cfm?strongs=H9&t=KJV\\\" title=\\\"English: lost thing, that which was lost\\\"><span class=\\\"Hb\\\">אֲבֵדָה</span> (H9)</a>, incorrectly written for <a class=\\\"nowrap\\\" href=\\\"lexicon.cfm?strongs=H11&t=KJV\\\" title=\\\"English: destruction\\\"><span class=\\\"Hb\\\">אֲבַדּוֹן</span> (H11)</a> ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}