# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\(([H|G]{1}[0-9]+)\)"
test_str = "<span style=\\\"color: red; font-weight: bold;\\\"> (G4) The same as <a class=\\\"nowrap\\\" href=\\\"lexicon.cfm?strongs=H9&t=KJV\\\" title=\\\"English: lost thing, that which was lost\\\"><span class=\\\"Hb\\\">אֲבֵדָה</span> (H9)</a>, incorrectly written for <a class=\\\"nowrap\\\" href=\\\"lexicon.cfm?strongs=H11&t=KJV\\\" title=\\\"English: destruction\\\"><span class=\\\"Hb\\\">אֲבַדּוֹן</span> (H11)</a> "
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.