const regex = /\(([H|G]{1}[0-9]+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(([H|G]{1}[0-9]+)\\)', 'gm')
const str = `<span style=\\"color: red; font-weight: bold;\\"> (G4) The same as <a class=\\"nowrap\\" href=\\"lexicon.cfm?strongs=H9&t=KJV\\" title=\\"English: lost thing, that which was lost\\"><span class=\\"Hb\\">אֲבֵדָה</span> (H9)</a>, incorrectly written for <a class=\\"nowrap\\" href=\\"lexicon.cfm?strongs=H11&t=KJV\\" title=\\"English: destruction\\"><span class=\\"Hb\\">אֲבַדּוֹן</span> (H11)</a> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}