use strict;
my $str = '<span style=\\"color: red; font-weight: bold;\\"> (G4) The same as <a class=\\"nowrap\\" href=\\"lexicon.cfm?strongs=H9&t=KJV\\" title=\\"English: lost thing, that which was lost\\"><span class=\\"Hb\\">אֲבֵדָה</span> (H9)</a>, incorrectly written for <a class=\\"nowrap\\" href=\\"lexicon.cfm?strongs=H11&t=KJV\\" title=\\"English: destruction\\"><span class=\\"Hb\\">אֲבַדּוֹן</span> (H11)</a> ';
my $regex = qr/\(([H|G]{1}[0-9]+)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}