package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:(?:\d\d\/){1,2}\d{4}|\d\d)\b`)
var str = `12/12/2014.
I'm also trying to satisfy 12 and 12/2014.
the response value 10 (from here I want to extract 10)
the response value 10/12/2014 (from here I want to extract 10/12/2014)
the response value 08/2015 (from here I want to extract 08/2015)
\b(?:\d{2}\/\d{4}|\d{2}(?:\/\d{2}\/\d{4})?)\b
\b(?:(?:\d\d\/){1,2}\d{4}|\d\d)\b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}