$re = '/\b(?:(?:\d\d\/){1,2}\d{4}|\d\d)\b/m';
$str = '12/12/2014.
I\'m also trying to satisfy 12 and 12/2014.
the response value 10 (from here I want to extract 10)
the response value 10/12/2014 (from here I want to extract 10/12/2014)
the response value 08/2015 (from here I want to extract 08/2015)
\\b(?:\\d{2}\\/\\d{4}|\\d{2}(?:\\/\\d{2}\\/\\d{4})?)\\b
\\b(?:(?:\\d\\d\\/){1,2}\\d{4}|\\d\\d)\\b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);