import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:\\d\\d\\/){1,2}\\d{4}|\\d\\d)\\b";
final String string = "12/12/2014.\n\n"
+ "I'm also trying to satisfy 12 and 12/2014.\n\n\n"
+ "the response value 10 (from here I want to extract 10)\n"
+ "the response value 10/12/2014 (from here I want to extract 10/12/2014)\n"
+ "the response value 08/2015 (from here I want to extract 08/2015)\n\n"
+ "\\b(?:\\d{2}\\/\\d{4}|\\d{2}(?:\\/\\d{2}\\/\\d{4})?)\\b\n"
+ "\\b(?:(?:\\d\\d\\/){1,2}\\d{4}|\\d\\d)\\b";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}