# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:(?:\d\d\/){1,2}\d{4}|\d\d)\b"
test_str = ("12/12/2014.\n\n"
"I'm also trying to satisfy 12 and 12/2014.\n\n\n"
"the response value 10 (from here I want to extract 10)\n"
"the response value 10/12/2014 (from here I want to extract 10/12/2014)\n"
"the response value 08/2015 (from here I want to extract 08/2015)\n\n"
"\\b(?:\\d{2}\\/\\d{4}|\\d{2}(?:\\/\\d{2}\\/\\d{4})?)\\b\n"
"\\b(?:(?:\\d\\d\\/){1,2}\\d{4}|\\d\\d)\\b")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.