// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:(?:\d\d\/){1,2}\d{4}|\d\d)\b").unwrap();
let string = "12/12/2014.
I'm also trying to satisfy 12 and 12/2014.
the response value 10 (from here I want to extract 10)
the response value 10/12/2014 (from here I want to extract 10/12/2014)
the response value 08/2015 (from here I want to extract 08/2015)
\\b(?:\\d{2}\\/\\d{4}|\\d{2}(?:\\/\\d{2}\\/\\d{4})?)\\b
\\b(?:(?:\\d\\d\\/){1,2}\\d{4}|\\d\\d)\\b";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}