const regex = /\b(?:(?:\d\d\/){1,2}\d{4}|\d\d)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?:\\d\\d\\\/){1,2}\\d{4}|\\d\\d)\\b', 'gm')
const str = `12/12/2014.
I'm also trying to satisfy 12 and 12/2014.
the response value 10 (from here I want to extract 10)
the response value 10/12/2014 (from here I want to extract 10/12/2014)
the response value 08/2015 (from here I want to extract 08/2015)
\\b(?:\\d{2}\\/\\d{4}|\\d{2}(?:\\/\\d{2}\\/\\d{4})?)\\b
\\b(?:(?:\\d\\d\\/){1,2}\\d{4}|\\d\\d)\\b`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}