#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-9]|[0-8][0-9]|90)(?:\.\d+)?$"
Local $sString = "91" & @CRLF & _
"90" & @CRLF & _
"90.45" & @CRLF & _
"90.9999" & @CRLF & _
"0" & @CRLF & _
"0.23" & @CRLF & _
"9" & @CRLF & _
"80" & @CRLF & _
"71" & @CRLF & _
"7" & @CRLF & _
"2" & @CRLF & _
"0.12" & @CRLF & _
"3.4" & @CRLF & _
"33" & @CRLF & _
"68" & @CRLF & _
"54" & @CRLF & _
"901" & @CRLF & _
"92" & @CRLF & _
"91.1" & @CRLF & _
"90.99" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")