re = /^(?:[0-9]|[0-8][0-9]|90)(?:\.\d+)?$/m
str = '91
90
90.45
90.9999
0
0.23
9
80
71
7
2
0.12
3.4
33
68
54
901
92
91.1
90.99
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end