using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0-9]|[0-8][0-9]|90)(?:\.\d+)?$";
string input = @"91
90
90.45
90.9999
0
0.23
9
80
71
7
2
0.12
3.4
33
68
54
901
92
91.1
90.99
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}