# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[0-9]|[0-8][0-9]|90)(?:\.\d+)?$"
test_str = ("91\n"
"90\n"
"90.45\n"
"90.9999\n"
"0\n"
"0.23\n"
"9\n"
"80\n"
"71\n"
"7\n"
"2\n"
"0.12\n"
"3.4\n"
"33\n"
"68\n"
"54\n"
"901\n"
"92\n"
"91.1\n"
"90.99\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.