import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9]|[0-8][0-9]|90)(?:\\.\\d+)?$";
final String string = "91\n"
+ "90\n"
+ "90.45\n"
+ "90.9999\n"
+ "0\n"
+ "0.23\n"
+ "9\n"
+ "80\n"
+ "71\n"
+ "7\n"
+ "2\n"
+ "0.12\n"
+ "3.4\n"
+ "33\n"
+ "68\n"
+ "54\n"
+ "901\n"
+ "92\n"
+ "91.1\n"
+ "90.99\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}