using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bo{1,2}[\sh]?b\s?i{1,2}\b";
string input = @"obi
obi baumarkt
baumarkt obi
obi-baumarkt
baumarkt-obi
obiwan
tobi
grobian";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}