re = /\bo{1,2}[\sh]?b\s?i{1,2}\b/
str = 'obi
obi baumarkt
baumarkt obi
obi-baumarkt
baumarkt-obi
obiwan
tobi
grobian'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end