import re
regex = re.compile(r"\bo{1,2}[\sh]?b\s?i{1,2}\b")
test_str = ("obi\n"
"obi baumarkt\n"
"baumarkt obi\n"
"obi-baumarkt\n"
"baumarkt-obi\n"
"obiwan\n"
"tobi\n"
"grobian")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")