const regex = /\bo{1,2}[\sh]?b\s?i{1,2}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bo{1,2}[\\sh]?b\\s?i{1,2}\\b', 'g')
const str = `obi
obi baumarkt
baumarkt obi
obi-baumarkt
baumarkt-obi
obiwan
tobi
grobian`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}