import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bo{1,2}[\\sh]?b\\s?i{1,2}\\b";
final String string = "obi\n"
+ "obi baumarkt\n"
+ "baumarkt obi\n"
+ "obi-baumarkt\n"
+ "baumarkt-obi\n"
+ "obiwan\n"
+ "tobi\n"
+ "grobian";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}