// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bo{1,2}[\sh]?b\s?i{1,2}\b").unwrap();
let string = "obi
obi baumarkt
baumarkt obi
obi-baumarkt
baumarkt-obi
obiwan
tobi
grobian";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}