import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([A-Z][a-z](?:,[A-Z][a-z])*\\)$";
final String string = "Super Mario Bros. 8 (En,Fr,De,Es,It)\n"
+ "Donald Duck in Whacky Land (En,Fr,De,Es,Sv)\n"
+ "Toadstool Adventures 3D (En)\n"
+ "Chinaland (En,De)\n"
+ "Another Title (3rd saga!)";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}