const regex = /\([A-Z][a-z](?:,[A-Z][a-z])*\)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\([A-Z][a-z](?:,[A-Z][a-z])*\\)$', 'gm')
const str = `Super Mario Bros. 8 (En,Fr,De,Es,It)
Donald Duck in Whacky Land (En,Fr,De,Es,Sv)
Toadstool Adventures 3D (En)
Chinaland (En,De)
Another Title (3rd saga!)`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);