import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*<!\\[CDATA\\[de_DE\\]\\]>.*(?:\\r?\\n)?";
final String string = "<supported-languages>\n"
+ " <lang><![CDATA[en_US]]></lang>\n"
+ " <lang><![CDATA[es_ES]]></lang>\n"
+ " <lang><![CDATA[de_DE]]></lang>\n"
+ "</supported-languages>\n\n"
+ "<2ndsupported-languages>\n"
+ " <lang><![CDATA[en_US]]></lang>\n"
+ " <lang><![CDATA[es_ES]]></lang>\n"
+ " <lang><![CDATA[de_DE]]></lang>\n"
+ "</2ndsupported-languages>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}