re = /.*<!\[CDATA\[de_DE\]\]>.*(?:\r?\n)?/m
str = '<supported-languages>
<lang><![CDATA[en_US]]></lang>
<lang><![CDATA[es_ES]]></lang>
<lang><![CDATA[de_DE]]></lang>
</supported-languages>
<2ndsupported-languages>
<lang><![CDATA[en_US]]></lang>
<lang><![CDATA[es_ES]]></lang>
<lang><![CDATA[de_DE]]></lang>
</2ndsupported-languages>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result