# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\\/script>\s*\n)s$/$1/gm;t' <<< "<script type=\"text/javascript\"></script>
s"