re = /(<\/script>\s*\n)s$/m
str = '<script type="text/javascript"></script>
s'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result