use strict;
my $str = '<script type="text/javascript"></script>
s';
my $regex = qr/(<\/script>\s*\n)s$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";