const regex = /(<\/script>\s*\n)s$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\\/script>\\s*\\n)s$', 'gm')
const str = `<script type="text/javascript"></script>
s`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);