#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:\D*\d){10}(?:(?:\D*\d){3})?$)[\d-]+$"
Local $sString = "978-1-56619-909-4 2" & @CRLF & _
"978-1-56619-909-4" & @CRLF & _
"1-56619-909-3 " & @CRLF & _
"1-56619-909-3" & @CRLF & _
"isbn446877428ydh" & @CRLF & _
"55 65465 4513574" & @CRLF & _
"1257561035" & @CRLF & _
"1248752418865"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")