import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:\\D*\\d){10}(?:(?:\\D*\\d){3})?$)[\\d-]+$";
final String string = "978-1-56619-909-4 2\n"
+ "978-1-56619-909-4\n"
+ "1-56619-909-3 \n"
+ "1-56619-909-3\n"
+ "isbn446877428ydh\n"
+ "55 65465 4513574\n"
+ "1257561035\n"
+ "1248752418865";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}